[Atualização estável] 2019-07-17 – Kernels, KDE, navegadores, Systemd, Octopi, LibreOffice

Olá comunidade,

Tenho o prazer de anunciar que esperamos por uma atualização estável. Principalmente, temos os pacotes KDE e Mesa e precisamos de correções de segurança para o Firefox e o Thunderbird com este.

Alguns podem perceber que desde o #snapcraftsummit muitas mudanças no pacote foram para Manjaro e nossos RCs disponíveis. Também ainda não anunciamos o 18.1.0-rc3 oficialmente. Ainda estamos polindo a experiência do snap para nossos usuários. O XFCE e o Gnome virão com o Gnome-Software e a nossa edição do KDE possui o Discover , ambos com o suporte a snap ativado.

Dessa forma, todos podem acessar facilmente o snap store por um clique e não precisam se preocupar em ativar os snaps . Isso nos permite enviar software ainda mais proprietário, o que não podíamos antes. Por exemplo, confira como você pode instalar o Spotify no Manjaro.

Esta atualização contém as seguintes alterações:

  • A maioria dos nossos Kernels foi atualizada
  • O Octopi agora está no mais recente git-commit . Relatar de volta de qualquer regressão.
  • Calamares conseguiu as correções de segurança  necessárias. Se você quiser usar a criptografia luks, recomendamos veementemente o 18.1-rc4 ou posterior!
  • Última versão do Firefox e do Wine
  • Plasma5 está agora em 5.16.3
  • Os aplicativos do KDE estão agora em 19.04.3
  • KDE Frameworks está agora em 5.60
  • alguns dos pacotes XFCE , Gnome e Cinnamon foram atualizados
  • Um novo lançamento do LibreOffice saiu
  • Última versão do Mesa foi adicionado
  • Firefox está agora em 68.0 – Isso também foi empurrado para o nosso ramo estável .
  • Thunderbird está agora em 60,8
  • Algumas atualizações regulares de pacotes como Haskell , Evolution e Xorg
  • Os esforços mais recentes do KDE podem ser revistos através do nosso atual KDE-Dev ISO
  • Os ISOs do Manjaro Juhraya foram atualizados, incluindo suporte a snap pré-ativado: XFCE , KDE , Gnome

Dê-nos o feedback habitual e deixe-nos saber o que pensa sobre esta atualização.


Kernels suportados atuais

  • linux316 3.16.70
  • linux44 4.4.185 (nenhum módulo nvidia-340 legado!)
  • linux49 4.9.185
  • linux414 4.14.133
  • linux419 4.19.59
  • linux51 5.1.18
  • linux52 5.2.1 (sem módulo catalisador!)
  • linux419-rt 4.19.50_rt22
  • linux50-rt 5.0.21_rt16

Atualizações de pacote (terça-feira 16 de julho 07:25:33 CEST 2019)

  • comunidade estável x86_64: 1020 pacotes novos e 1016 removidos
  • core estável x86_64: 35 novos e 34 pacotes removidos
  • extra estável x86_64: 739 novos e 832 pacotes removidos
  • multilib estável x86_64: 16 pacotes novos e 16 removidos

Uma lista detalhada de todas as mudanças no pacote pode ser encontrada aqui .

Problemas e soluções conhecidos

libbloom> = atualização 1.6-2 requer intervenção manual

(Extraído do site Arch Linux, 2019-07-11 por Felix Yan. Fonte: https://www.archlinux.org/news/libbloom16-2-update-requires-manual-intervention )

O pacote libbloom anterior à versão 1.6-2 não possuía um link soname. Isso foi corrigido em 1.6-2, então a atualização precisará sobrescrever o link soname não rastreado criado pelo ldconfig. Se você receber um erro

libbloom: /usr/lib/libbloom.so.1 exists in filesystem

ao atualizar, use

pacman -Suy --overwrite usr/lib/libbloom.so.1

para executar a atualização.

 

 

 

 

 

 

Esta postagem é apenas uma tradução, o original você encontra aqui.

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s

Este site utiliza o Akismet para reduzir spam. Saiba como seus dados em comentários são processados.