Módulo de Segurança para o Banco do Brasil. [Atualizado 23/05/2017]

Muitos usuários que utilizam a base Arch e precisa acessar o Banco do Brasil tem que usar o smartphone, virtualbox, entre outros métodos. No dia 08/03 foi enviado para a AUR o warsaw destinado aos clientes do BB, desde então estamos acompanhando o processo.

Se você utiliza outro banco, leia nossa dica do warsaw para vários bancos aqui.

Instalação.
Modo gráfico: procure e instale o warsaw.
Terminal: use o comando abaixo.
yaourt -S warsaw

Iniciar o serviço
Use o comando abaixo para iniciar o warsaw.
systemctl start warsaw.service

Iniciar junto com o sistema.
Use o comando abaixo.
systemctl enable warsaw.service

Reinicie o sistema após os passos acima.

Parar o serviço
Use o comando abaixo para parar o warsaw.
systemctl stop warsaw.service

Retirar da inicialização do sistema.
Use o comando abaixo.
systemctl disable warsaw.service

Observações do Blog.
Se você usar o comando para o warsaw iniciar junto com o sistema e ele não funcionar quando for acessar sua conta, faça a seguinte modificação.

Abra e edite o arquivo warsaw.service com o comando abaixo. (troque kate pelo editor de texto do sistema)
sudo kate /usr/lib/systemd/system/warsaw.service

Adicione /usr/bin/warsaw/wsatspi ao arquivo. (note que existe um espaço entre o primeiro comando)

[Unit]
Description=Warsaw Technology (core)
After=remote-fs.service
After=syslog.target

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStartPre=/usr/bin/warsaw/wscertmgr /usr/bin/warsaw/wsatspi
ExecStart=/usr/bin/warsaw/core

[Install]
WantedBy=multi-user.target

Salve , feixe o arquivo e reinicie o sistema para que as mudanças entrem em vigor.

Navegadores funcionando.
Firefox

 

Se você gosta de algum programa e não achou ele no Manjaro,deixe um comentário com o nome do programa que vamos procurar algo equivalente,e se possível entrar em contato com algum desenvolvedor para fazer um port para o Manjaro.

Não esqueça de compartilhar nas redes sociais para que mais pessoas saibam sobre os programas e para incentivar o blog a continuar trazendo mais conteúdo bacana sobre esta distro maravilhosa.

Facebook

Twitter

Google+

Canal no Telegram

Anúncios

15 comentários em “Módulo de Segurança para o Banco do Brasil. [Atualizado 23/05/2017]

  1. Tive os seguintes problemas na instalaçao do warsaw.
    (1/1) verificando conflitos de arquivo [##############################################] 100%
    erro: falha em submeter a transação (arquivos conflitantes)
    warsaw: /etc/xdg/autostart/warsaw.desktop existe no sistema de arquivos
    warsaw: /usr/local/bin/warsaw existe no sistema de arquivos
    warsaw: /usr/local/etc/warsaw existe no sistema de arquivos
    warsaw: /usr/local/lib/warsaw existe no sistema de arquivos
    warsaw: /usr/share/fonts/truetype/dbldwrsw.ttf existe no sistema de arquivos

    Ocorreram erros e, portanto, nenhum pacote foi atualizado.

    Assim, tentei executar o warsaw, sem exito. vou tentar instalar novamente.

    Curtir

  2. Oá.
    Já instalei, atualizei, desinstalei e instalei novamente, mas ainda aparece a seguinte mensagem:

    Prezado cliente, você não possui o Módulo de Segurança instalado neste computador e não possui nenhum celular cadastrado.

    não consigo acessar minha conta e nem fazer comprar online.

    Curtir

    1. Olá Gustavo
      Infelizmente, por algum motivo ele funciona com alguns usuários e outros não.
      Eu estou sempre verificando novas opções, mas no momento, temos que esperar uma solução que funcione para todos.
      Saudações.

      Curtir

  3. Estou tentando instalar o Warsaw e no final recebo
    Makefile:761: *** missing separator. Pare.
    ==> ERRO: Uma falha ocorreu em package().
    Abortando…
    ==> ERRO: Makepkg não conseguiu compilar warsaw.
    ==> Reiniciar a compilação de warsaw ? [s/N]
    Pode ajudar?

    Curtir

    1. Olá Haroldo
      Você tentou instalar mais de uma vez?
      Eu acabei de instalar aqui e não houve nenhum erro, procurei se alguém na AUR teve o mesmo problema, mas não encontrei nada.
      Vou ficar verificando sobre o assunto, tente reinstalar e veja se é acusado mais alguma informação.

      Curtir

      1. Lembrei de algo:no início da instalação, recebo
        warsaw 1.12.3.11-2 (2017-04-07 18:02)
        ( Pacote sem suporte: Potencialmente perigoso ! )
        ==> Editar PKGBUILD ? [S/n] (“A” para abortar)
        Marco n e tenho o resultado de não instalar. Algo sobre isso?
        Grato pela atenção

        Curtir

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

w

Conectando a %s